Neutrino goes 4K (HD51) - Diskussion & Rückmeldungen

    • Da würde ich "-1" (gedanklich = false) eher als "immer komplett aus" oder "nie" definieren. Dann ist das Schaltproblem doch gelöst. Das würde ja dem #ifdef 0 - Zweig aus dem besagten Fix entsprechen.

      Und die "0" - wie bisher - als "keine Automatik" = manuell ein/aus.
      Ist dann halt null Timeout festgelegt!

      Also kein Timeout == auch kein automatisches Aufpoppen (da die Zeit zwischen Start und Ende gleich 0 ist)
      Wenn es aber per Tastendruck aufpoppen soll, ist "ohne" Timeout auch das Ende nur manuell zu erreichen.

      (Was man allerdings im Moment mit einer numerischen Programmwahl und der dabei angezeigten Teil-Info auch erreicht)
    • Moin

      Die Idee zum ausschalten ist ja generell nicht schlecht, wenn man es unbedingt haben möchte. :)
      Im Kurztest funktionierts auch schon mal.
      Allerdings das jetzt bei deaktiviert auch bei drücken der Infotaste gar nichts mehr angezeigt wird, also die Funktion auch für die Sendungsinfo tot ist, ist so gewollt?

      Sollten sich die Jungens die es haben möchten vielleicht mal zu äussern.

      ich lasse es mal deaktiviert und mal schaun, ob Probleme am Wochenende im Betrieb auftauchen.
      Danke erstmal an dbt für die Umsetzung

      gr. Knicko
      Zee² , Link, Neo², D-Box2
    • Nachdem ich den Patch in meine NI-Sourcen eingearbeitet und für die AX kompiliert habe :

      TV = deaktiviert (neu)
      => kein Infobar, nur ein kurzes Zucken beim Umschalten und das Umschalten dauert - gefühlt - erheblich länger !
      Wenn man Cursor links=Infobar konfiguriert hat, spratzt das bei Druck auf diese Taste auch kurz auf.
      Wie bereits vorher schon erwähnt: Dieses Verhalten ist ziemlich sinnfrei! Keine Ahnung wer nach den bewährten "0 Sekunden" den Wert "aus" eingeführt hat und damit die Coder auf den Deaktiviert-Baum geschickt hat!
      Ich war es jedenfalls nicht.

      TV = Kein Timeout (das ehemalige "0 Sekunden" ?)
      => Das blöde Ding poppt wieder bei jedem Programmwechsel auf, lässt sich aber nur manuell abschalten. Das ist keine Verbesserung, sondern fördert das Karpaltunnel-Syndrom für den Exit-Daumen. Auch da erschließt sich mir keine wirkliche Anwender-Option.

      Radio = Kein Timeout
      => jetzt poppt es nicht auf, sondern muss manuell aktiviert werden, verschwindet aber beim Programmwechsel.
      (Und beim Bildschirmschoner wohl auch)

      Vor dem damaligen Commit war Alles so wie es gewünscht war und sein sollte, wenn man das Timeout auf "0" stellt:
      * Es kommt keine automtische Infobar mehr! (Weil mit Timeout nach 0 Sekunden auch keine "Time" über war)
      * Wenn man eine Infotaste (oder eine adäquate) drückt, erscheint das Infofeld und bleibt auch beim Zappen an.
      * Wenn man über die Kanal-/Bouquetliste wechselt oder numerisch wählt geht, bleibt das Teil wieder aus.
      * In allen anderen Fällen kann man per Exittaste (oder adäqauter) das Infofeld abschalten.


      Ich frage nochmal ganz ernsthaft:
      Warum macht Ihr den Fix nicht einfach wieder rückgängig und sitzt eine eventuelle akademische Korinthenkackerei bzgl. "Aus meint Aus" ganz einfach aus ? Oder schreibt einfach wieder "0"-Sekunden in die Timeout-Einstellungen.
      Beschwert hatte sich da vorher wohl auch Keiner drüber. Ich hab' jedenfalls in der Richtung nix gelesen.

      Dann bliebe nur noch, das Verhalten des TV-Modus für den Radio-Modus identisch zu machen und Alles ist gut...
    • Ich hatte das auch immer so verstanden: Infobar-Timeout = aus - und nicht Infobar = aus.
      Und mit dem dort diskutierten Revert in den NI-Sourcen (und meinem privaten Revert in den Tuxbox-Sourcen) funktioniert das ja auch wieder wie zuvor.
      Das bei "aus" abweichende Handling im RadioMode war schon immer so. Das sollte wirklich mit dem TVMode vereinheitlicht werden. Ist z.B. interessant zum schnellen Auffinden von Radiosendern mit RadioText.

      Zu den Mediplayer-Modes habe ich leider keine Meinung, da das bei mir
      a) selten benutzt wird , und
      b) ich die Timeouts dort tatsächlich "auf meine durchschnittliche Lesezeit" eingestellt habe.
      Freak-Zappen geht in dieses Modes halt eh nicht... ^^
    • @Janus: Nur zur Kenntnisname, der Patch selbst war noch fehlerhaft und die in dem Patch dafür gewählten Optionsbezeichnungen sind nicht in Stein gemeißelt. Sogesehen wäre zB. "ohne Timeout" und/oder "manuell" wohl die idiotensicherere Wahl ;-). Ich hatte das vorher allerdings auch nicht anders verstanden und keine andere Funktionalität erwartet, also wenn der Infobalken zu sehen ist, erst wieder verschwindet, wenn man ihn händisch wegdrückt. Und das macht der aktuelle Stand mit Fix nicht anders. Da muss ich allerdings auch mal ernsthaft fragen, wer unter der Funktionalität Timeout = 0 bzw. "aus" etwas anderes versteht als "kein Timeout" oder "Timeout aus"? Sven bringt es eigentlich auf en Punkt.

      Was jetzt die "spezielle" Funktionalität mit Revert angeht, habe ich trotzdem aber noch Lücken im Plan was du wirklich "deaktiviert" haben willst, weil man aus deinen Ausführungen irgendwie immer egal wie oft und ob man es vor oder rückwärts ließt auf keinen eindeutigen Schluss kommt oder anders gesagt, wenn das meherere Leute lesen, haben wahrscheinlich die mehrere davon eine andere Interpretation. Ich hatte mit dem alten Stand ohne Fix auch keine Probleme, aber der Fix ist sogesehen eigentlich schlüssig, wenn man die Bezeichungen der Optionen so nimmt wie sie sind, wenn in diesem Thread nicht die Worte "deaktivieren" oder "abschalten" genannt worden wären.

      Janus schrieb:

      TV = deaktiviert (neu)
      ... Dieses Verhalten ist ziemlich sinnfrei!

      Ich halte das ehrlich gesagt auch für recht sinnlos, hat aber auch mit Timeout '0/aus' nicht wirklich etwas zu tun.

      Janus schrieb:

      ... die Coder auf den Deaktiviert-Baum geschickt hat!Ich war es jedenfalls nicht.

      Sicher?

      Janus schrieb:

      Da würde ich "-1" (gedanklich = false) eher als "immer komplett aus" oder "nie" definieren. Dann ist das Schaltproblem doch gelöst.

      Janus schrieb:

      Die Infobar lässt sich damit eben nicht abschalten!

      Das ist eben eine Sache der Interpretation. In dem Fall was man eben unter 'abschalten' versteht. Und je öfter die Begriffe 'deaktivieren', 'abschalten' gefallen sind, um so mehr hatte ich das auch so interpretiert. Mir gehts allerdings im Prinzip eigentlich nur darum, dem Benutzer die Optionen so zu vermitteln, dass da möglichst keine Fehlinterpretation rauskommt. Das hatte ich sinngemäß auch so schon mal weiter oben geschrieben. Es mag auch auch sein, dass sich da bisher auch keiner beschwert hat, was wohl eher daran liegt, dass die meissten diese Einstellung nicht anfassen und es bei den Standardwerten belassen. Aber wie man sieht, ist das doch nicht so ganz einfach, wenn es mal drauf ankommt. Das hat im gewissen Sinne auch dazu geführt, das Seife den Fix da rein gemacht hat und jetzt eine Diskussion darüber besteht. Das hat auch nichts mit...

      Janus schrieb:

      eine eventuelle akademische Korinthenkackerei
      ...zu tun. Das sind nur gewisse Mehrdeutigkeiten, die jetzt auftauchen.

      Hier nochmal : 0002_tuxbox-neutrino_infobar_behavior.patch aber ich sags ausdrücklich: ohne Gewähr. ;)
    • dbt schrieb:

      Was jetzt die "spezielle" Funktionalität mit Revert angeht, habe ich trotzdem aber noch Lücken im Plan was du wirklich "deaktiviert" haben willst, weil man aus deinen Ausführungen irgendwie immer egal wie oft und ob man es vor oder rückwärts ließt auf keinen eindeutigen Schluss kommt


      Bis zum Commit von Seife war im Verhalten keine Änderung mehr, seitdem ich genau den unten beschriebenen Feature-Request für timeout=0 erfüllt bekam.
      Ich meine, das war ziemlich eindeutig beschrieben:

      von mir schrieb:

      Vor dem damaligen Commit war Alles so wie es gewünscht war und sein sollte, wenn man das Timeout auf "0" stellt:


      * Es kommt keine automtische Infobar mehr! (Weil mit Timeout nach 0 Sekunden auch keine "Time" über war)
      * Wenn man eine Infotaste (oder eine adäquate) drückt, erscheint das Infofeld und bleibt auch beim Zappen an.
      * Wenn man über die Kanal-/Bouquetliste wechselt oder numerisch wählt geht, bleibt das Teil wieder aus.
      * In allen anderen Fällen kann man per Exittaste (oder adäqauter) das Infofeld abschalten.

      Das gibt eigentlich wenig Spielraum für Interpretationen.
      Dass es Unterschiede zwischen TV-, Radio-, und den Mediaplayer-Modes gab und vor Deinem letzten Patch noch gibt, ist sicher ein Grund das Ganze konsistent zu machen. Aber nicht, indem man eins der vorhandenen Features per #if 0 einfach weg"optimiert". Mit dieser Änderung gab's bei Eistellung "aus" nämlich keine Möglichkeit mehr, die Infobar zu sehen. Weder auomatisch noch manuell. Das entsprach dann in Deinem Patch der Einstellung "deaktiviert".

      Nach meiner Auffassung müssen die folgenden Verhaltensweisen verfügbar sein:
      1. Default
      Infobar erscheint automatisch nach Programmwechsel - inkl. Startsender beim 'Einschalten' - mit einstellbarer Zeit für die Darstellung. Infobar verschwindet automatisch nach Erreichen der eingestellten TimeOut-Zeit - oder sofort nach einer gedrückten Abbruch-Taste (Exit, Home, Okay) für die Info-Anzeige.
      Das sollte das Standard-Verhalten sein.

      2. Manuell
      Infobar erscheint nie automatisch sondern nur, wenn man die Taste für die Anzeige der Infobar drückt (Info, Cursor links). Das passiert im Übrigen auch, wenn man nach Ablauf der TimeOut-Zeit im Verhalten 1 diese Tasten drückt !
      In diesem Verhalten 2 soll die Infobar bei Programmwechsel aber sichtbar bleiben, bis die definitiv manuell abgeschaltet wird.
      In der Version der letzten Jahre funktionierte das aber nur, wenn man die Programme in der Reihenfolge der zugrundeliegenden Kanalliste mit Programm+ und Programm- umschaltete. Mir reicht das aus, da man im Einzelfall ja Selektion und Sortierung vorab einstellen kann. Es dürfte auch aufwändig sein, nach einer Bouquet- oder Kanalliste anschließend wieder die Infobar des nunmehr ausgewählten Programms anzuzeigen. Aber wenn es ginge - z.B per infobar_active = true/false für den Modus manuell - wäre das auch ganz schön.

      a/b. Sonderverhalten bei EPG-Änderungen
      Das ist im Moment mit einem eigenen Schalter versehen. a=ein, b=aus

      Nach meinem Dafürhalten ist das aber nur sinnvoll, wenn auch Verhalten 1 in der Grundeinstellung gewählt ist und weil da auch ein TimeOut definiert ist.
      Für das Verhalten 2 dürfte aber - im Falle von a=ein - die EPG-Änderung nur angezeigt werden, wenn die Infobar sichtbar ist (also infobar_active=true)
      Dann sollte z.B. im Radio-Modus aber auch der Wechsel des Songtitels angezeigt werden.

      Eine zusätzliche Einstellung "deaktiviert" ist danach nicht notwendig, weil ja Jedermann Verhalten 2 einstellen kann und dann nie auf die Infotaste drückt (und die "Infos zur Sendung" generell über das rote Benutzermenü aufruft)


      Wie gesagt, ich habe diese #if 0 - Direktive auch in meinen Sourcen (Basis tuxbox-Repo) wieder rückgängig gemacht, nachdem das im NI-Source schon so wieder revertet war. Hier laufen beide Images wieder nach den o.g. Verhaltensweisen.

      Meine Einstellungen:
      Infobar =aus
      Infobar (Radiobetrieb) = aus
      Infobar (Mediaplayer Audio) = 2s
      Infobar (Mediaplayer Audio) = 4s

      Info bei EPG-Änderungen = aus

      Wobei im Radiomodus die Infobar aktuell auch - abweichend - durch einen einfachen Programmwechsel mit +/- ausgeschaltet wird.

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Janus ()

    • Moin

      Mich verwirrt das jetzt auch langsam. :D

      Mit der Option manuell, ohne timeout, habe ich jetzt wieder das wohl gewünschte Verhalten.
      Heißt, infobar beim zappen aus, mit Infotaste wieder dauerhaft an,bis ich es mit exit beende.
      So soll es ja auch glaube ich sein.

      nur wird angezeigt lt. Beschreibung dauerhaft an.

      Quellcode

      1. +menu.hint_osd_behavior_infobar Zeige Infobar je nach Zeiteinstellung oder dauerhaft mit der Option "manuell, ohne Timeout".
      manuell-ohne-timeout.png

      müsste doch eigentlich "dauerhaft aus" heißen.

      gr. Knicko
      Zee² , Link, Neo², D-Box2
    • Habe den zweiten Patch in die aktuellen Sourcen für HD1/Nevis eingearbeitet und per bs4cs für die Neo kompiliert.
      Das Verhalten ist damit wieder wie gewohnt. Ich denke "manuell, ohne Timeout" bringt diese Option auch sprachlich auf den Punkt. Der Hinweistext passt auch.

      Es fehlt aber noch die Vereinheitlichung für den Radio-Modus. Da wird zwar das manuelle Einschalten realisiert, "ohne Timeout" wird aber durch Programm+/- unterlaufen. Die Infobar ist danach weg.
      Liegt möglicherweise an leicht abweichendem Message-Handling im Radio-Modus ?!?



      Ein völlig anderer Fehler ist mir letztlich noch aufgefallen:
      Beim Scan werden hier keine Transponderparameter bei "Frequenz" mehr angezeigt. (Ist noch nicht lange so, eine Version vom Januar macht das noch richtig)-
      Kann das Jemand nachstellen ?
    • Janus schrieb:

      Es fehlt aber noch die Vereinheitlichung für den Radio-Modus. Da wird zwar das manuelle Einschalten realisiert, "ohne Timeout" wird aber durch Programm+/- unterlaufen. Die Infobar ist danach weg.
      Liegt möglicherweise an leicht abweichendem Message-Handling im Radio-Modus ?!?
      Dazu müsste sich gemerkt werden, ob der Infoviewer beim Umschalten offen war. Dementsprechend müsste er dann wieder gestartet werden (oder eben auch nicht). Beim Zap wird der Infoviewer immer abgemurkst und dann neu gestartet. Der Neustart wird bei "timeout = 0" aber unterbunden.
      Sich den Status zu merken und dann darauf zu reagieren, sollte aber kein Hexenwerk sein.
      Das betrifft aber doch nicht nur den Radiomodus, oder?
    • Im Radiomodus geht das - im Gegensatz zum TV-Modus - schon beim 'normalen' Senderwechsel per Programm+ oder Programm- wieder aus. Das sollte aber beim Zappen auch im Radiomodus anbleiben.

      Was das "Überleben" der aktivierten Infobar auch bei anderen Auswahl-Operation oder sonstigen 'Ablenkungen' - wie z.B. den Bildschirmschoner - betrifft, so bin ich nicht wirklich sicher, ob das sein muss.
      Ich benutze das Faeture "as is" in der Hauptsache zur Kontrolle und Pflege meiner Bouquets nach einem Scan. Was bei mir sehr häufig vorkommt.
      Und im laufenden Betrieb, um z.B. ein Genre-Bouquet (ohne EPG-Hintergrundaktualisierung) per "Durchdackeln" komplett mit frischen EPG auszustatten. In der Infobar kann ich dann sofort erkennen, ob der aktuelle EPG eingelesen wird (oder keiner gefunden wurde).

      Wie früher schon gesagt, das ist ein Feature für Settingsfreaks und Anwender mit DXer-Anwandlungen.
      Und durch die vielen Möglichkeiten zur Selektion und Sortierung von Sendern die mir Neutrino freundlicherweise zur Verfügung stellt, kann ich das für die eigentliche 'Arbeit' soweit 'vorbereiten', dass ich ohne dieses "Überleben unter allen Umständen" (oder ein dafür notweniges Aktiv-Flag) zurechtkomme. Und da gibt es ja auch noch die Fernbedienung...
      Zumal das vieleicht kein Hexenwerk ist, aber durch die nach meiner Schätzung recht vielen kleinen Baustellen quer durch die Sourcen doch schon recht umfangreich und fehleranfällig werden dürfte.

      Also ich wäre zufrieden, wenn die anderen zap-fähigen Modi sich genau so verhalten, wie im Moment der TV-Modus.
    • Ich habe das heutige Yocto-Poky Image auf meiner Mutant HD51 installiert, leider geht es nach dem zweiten Booten nicht weiter. Das Letzte , was bei mir ging, ist das vom 9.4.18. Ich nehme das Mp-Flavour für ofgwrite. Was ist der Unterschied zum Image ohne Flavour, auf was muss ich noch achten? Das Image war immer sehr schnell, schade, dass es bei mir nicht mehr geht. Besten Dank! Clausi
    • Hi. Das ist bedingt durch eine Änderung am verwendeten yocto Branch (es wird jetzt der aktuelle yocto Release sumo verwendet) und eine Anpassung an der Sicherung.

      Es funktioniert in jedem Fall wieder, wenn Du vor der Installation die Sicherung löschst und hinterher neu anlegst

      Angenommen, das Image liegt bei dir in Partition 3, würde ich so vorgehen:

      per telnet verbinden
      rm -r /media/HDD/service/partititon3
      flash 3

      Jetzt wird das aktuelle Image geladen und in die 3. Partition installiert

      Danach müsstest Du aber leider wieder neu einrichten
    • Neu

      Diverse YT-Streams bringen error.

      Quellcode

      1. #EXTM3U name="YouTube - JP Performance" type=mp4 plugin=youtube
      2. #EXTINF:0 logo=http://i.ytimg.com/vi/xjFZvMFZaBY/mqdefault.jpg ,JP Performance - VW Polo GTI Probefahrt
      3. https://www.youtube.com/watch?v=xjFZvMFZaBY&feature=youtube_gdata

      Quellcode

      1. PlayFileStart: starting...
      2. stopPlayBack: stopping...
      3. stopPlayBack: stopped
      4. Startplay at 0 seconds
      5. CMoviePlayerGui::handleMovieBrowser: reset vars
      6. cutNeutrino: playing 0 isUPNP 1
      7. IS FILE PLAYER: true
      8. [LT:005f41b0:play ] Open - player output name: Output PlayMode: PLAYMODE_FILE
      9. [LT:005f41b0:play ] Start - filename=http://192.168.178.6:4044/proxy/0_19_1.mp4 vpid=0 vtype=0 apid=0 ac3=57324
      10. {"FF_ERROR":{"msg":"End of file","code":-541478725}}
      11. [LT:005f41b0:play ] Close
      12. CMoviePlayerGui::PlayFile: exit, isMovieBrowser 0 p_movie_info (nil)
      13. CMoviePlayerGui::handleMovieBrowser: stop, isMovieBrowser 0 p_movie_info (nil)
      14. PlayFileEnd: stopping, this 0x5f4b30 thread 0xdac64
      15. [LT:005f41b0:play ] SetSpeed playing 0 speed 1
      16. [LT:005f41b0:play ] Close
      17. restoreNeutrino: playing 1 isUPNP 1
      18. PlayFileEnd: stopped
      Alles anzeigen